VirtualBox is not installed


Advanced search

Message boards : Number crunching : VirtualBox is not installed

Author Message
wertperch
Send message
Joined: 1 May 15
Posts: 5
Credit: 0
RAC: 0
Message 2263 - Posted: 5 May 2015, 8:04:40 UTC

I've downloaded the newest BOINC Manager update with VirtualBox, tried two installations and yet still I get the message "VirtualBox is not installed" whenever I try to update ATLAS.

I'm probably missing something really basic, so if one of you would advise me, I'd be grateful.

Running in Windows 7 on a Gateway Celeron-powered laptop, in case that throws any light on things.

etalhod
Send message
Joined: 4 Dec 14
Posts: 56
Credit: 30,151
RAC: 0
    
Message 2264 - Posted: 5 May 2015, 8:27:44 UTC - in response to Message 2263.

Hi,

Is this your first installation? Or the BOINC was already running on your machine?

If it's only an update you don't have to install the virtual machine again, you can only update the BOINC version.

wertperch
Send message
Joined: 1 May 15
Posts: 5
Credit: 0
RAC: 0
Message 2265 - Posted: 5 May 2015, 14:37:39 UTC - in response to Message 2264.

Have been running BOINC for ages, but first installation of the VirtualBox variety.

Profile MAGIC Quantum Mechanic
Avatar
Send message
Joined: 4 Jul 14
Posts: 332
Credit: 485,372
RAC: 0
    
Message 2268 - Posted: 6 May 2015, 0:39:26 UTC - in response to Message 2265.

Hello wertperch,

You will have several problems trying to run the Atlas tasks with your 2-core laptop with less than 4GB Ram

And another problem may be that your laptop does NOT have the Virtualbox enabled in the Bios.

That you can check as you are booting up by pressing the proper key (such as F9)

There you can look around and enable it if it needs to be.

But even if you can do this you still will be lucky to run just ONE Atlas task at a time and leaving the 2nd core *free

I have been running these Cern VB tasks since 2011 and once in a while I do updates with Boinc and Oracle VB and many times it would D/L and install and then tell me the same thing you see now.

Every time I would start by rebooting after to see if that will get the VB to run (remember of course you have to have it enabled in the Bios first)

And when THAT didn't work I would just go to the Oracle VB site and d/l one of the newer (and proper) version again and make sure you d/l the proper *Extension Pack* there https://www.virtualbox.org/wiki/Downloads

BUT as I mentioned you don't have enough Ram to run these tasks to complete.

So once you make sure the VB is enabled in your Bios and you have the VB and Extension Pack installed and able to run maybe you should try running the Cern vLHC tasks where we run 2 tasks at a time and the tasks are all approx. 24 hours each and these tasks also use the VB but it is also updated with a wrapper that makes them run better and they also don't use near as much Ram aka memory to run and you do have enough to run those.

http://lhcathome2.cern.ch/vLHCathome/index.php and if you have any questions of course somebody will help you with that.
____________

Profile Georg Stoifl
Avatar
Send message
Joined: 28 Oct 14
Posts: 75
Credit: 5,187,269
RAC: 0
    
Message 2270 - Posted: 6 May 2015, 21:17:40 UTC

Hi,

If you start the Virtual Box Manager, try to create a new VM, does it allow to select a 64bit operating system?

Georg

Profile MAGIC Quantum Mechanic
Avatar
Send message
Joined: 4 Jul 14
Posts: 332
Credit: 485,372
RAC: 0
    
Message 2271 - Posted: 7 May 2015, 1:59:52 UTC - in response to Message 2263.
Last modified: 7 May 2015, 2:00:43 UTC

(maybe he gave up)

wertperch
Send message
Joined: 1 May 15
Posts: 5
Credit: 0
RAC: 0
Message 2273 - Posted: 8 May 2015, 19:10:50 UTC - in response to Message 2271.

(maybe he gave up)


Nope, not given up quite yet; I'm going to be trying all these suggestions once I actually am home and have the time!

Dirk Broer
Send message
Joined: 26 Jul 14
Posts: 7
Credit: 54,473
RAC: 0
    
Message 2274 - Posted: 10 May 2015, 9:05:07 UTC - in response to Message 2273.

Do not forget to install the Virtual Box extensions too (seperate download).

wertperch
Send message
Joined: 1 May 15
Posts: 5
Credit: 0
RAC: 0
Message 2275 - Posted: 12 May 2015, 17:36:50 UTC - in response to Message 2274.

Good grief. Normally a fairly patient chap, but now I give up! After several downloads of several different things, umpteen OS restarts and attempts to do things in the BIOS, I quit. Clearly the computing gods in this laptop don't want me to run ATLAS.

To be frank, I want things that a) run out of the box, and b) work as advertised. Failing that, a good FAQ/manual. BOINC was supposed to cover all of this, or so I thought.

Profile Jim1348
Send message
Joined: 15 Nov 14
Posts: 111
Credit: 1,319,885
RAC: 0
    
Message 2276 - Posted: 12 May 2015, 18:08:54 UTC - in response to Message 2275.
Last modified: 12 May 2015, 18:11:07 UTC

If you don't have enough RAM (6 GB is probably a reasonable minimum, though 8 GB would be better), then it won't work, as Magic has pointed out. But sometimes VB has permission problems of some sort, and you need to install in something like "WinXP Sp3 compatibility mode". Even that does not work sometimes though.

wertperch
Send message
Joined: 1 May 15
Posts: 5
Credit: 0
RAC: 0
Message 2277 - Posted: 12 May 2015, 21:12:30 UTC - in response to Message 2276.

Ah, okay. Maybe I'll try again when I build my megabeast desktop machine. Thank you all for your help!

Profile tullio
Send message
Joined: 27 Jun 14
Posts: 256
Credit: 289,886
RAC: 0
    
Message 2279 - Posted: 13 May 2015, 6:02:40 UTC

You cold run vLHC@home tasks. Both regular and Databridge test tasks use 256 MB each, and you cannot run more than two tasks.
Tullio

[AF>Belgique] MK
Send message
Joined: 29 Sep 14
Posts: 3
Credit: 3,111
RAC: 0
  
Message 6005 - Posted: 17 Jan 2017, 4:01:21 UTC - in response to Message 2279.

Having the same issue here. Actually, it's crazy because I have one active task. It is running using VM .. but no new tasks are downloaded and the log says.

Mon 16 Jan 2017 10:56:01 PM EST | ATLAS@home | Message from server: VirtualBox is not installed

[AF>Belgique] MK
Send message
Joined: 29 Sep 14
Posts: 3
Credit: 3,111
RAC: 0
  
Message 6006 - Posted: 17 Jan 2017, 4:17:52 UTC - in response to Message 6005.

solved... I just uninstalled and re-installed boinc and now it can work again with VB.

Message boards : Number crunching : VirtualBox is not installed